* * *

Author Topic: Android Module Wizard  (Read 412249 times)

m4u_hoahoctro

  • Full Member
  • ***
  • Posts: 155
Re: Android Module Wizard
« Reply #1035 on: May 16, 2018, 06:14:00 am »
@jmpessoa
With lamw v0.8, i cant run app demos on my Galaxy J1 anymore (it crashes) ( it works with old lamw version )
I dont know why, I still use ndk r10e, sdk t25, set up paths needed
But building apk file runs well, and running my own app designed by lamw v0.8 works

update: I tried running your app demos on another uses android 6.0 and it still be
« Last Edit: May 16, 2018, 06:23:12 am by m4u_hoahoctro »

jmpessoa

  • Hero Member
  • *****
  • Posts: 1111
Re: Android Module Wizard
« Reply #1036 on: May 16, 2018, 07:07:32 am »

Mybe, "D:\"

I will do some tests...

Thank you!
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

m4u_hoahoctro

  • Full Member
  • ***
  • Posts: 155
Re: Android Module Wizard
« Reply #1037 on: May 17, 2018, 06:20:05 am »

Mybe, "D:\"

Yes. When I create new Lamw GUI
Below dialog appears, but i havent never seen it before ( with old lamw version )

Update: Using
 -SDK r25
 -NDK r16b
- Building and Starting Compat Theme-Used App run well
- Building is ok, but Starting Older Example Apps ( uses Ant to build ) crashes when starting
- About the dialog "....ndk/toolchains.., change to ndl/toolchains", i dont know how to solve this
« Last Edit: May 17, 2018, 07:18:59 am by m4u_hoahoctro »

jmpessoa

  • Hero Member
  • *****
  • Posts: 1111
Re: Android Module Wizard
« Reply #1038 on: May 17, 2018, 08:07:54 am »
Hi m4u!

Use "Ctrl+C" to copy the [complete] message from dialog...

[there is some error when converting "the demo" path to your system...]
« Last Edit: May 17, 2018, 08:09:38 am by jmpessoa »
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

m4u_hoahoctro

  • Full Member
  • ***
  • Posts: 155
Re: Android Module Wizard
« Reply #1039 on: May 17, 2018, 01:06:14 pm »
Hi m4u!

Use "Ctrl+C" to copy the [complete] message from dialog...

[there is some error when converting "the demo" path to your system...]

Quote
[Window Title]
Confirmation

[Content]
Path "D:\ndk_r16b\toolchains\arm-linux-androideabi-4.9\prebuilt\windows\lib\gcc\arm-linux-androideabi\4.9.x\" does not exist.
Change it to "D:\ndk_r16b\toolchains\arm-linux-androideabi-4.9\prebuilt\windows-x86_64\lib\gcc\arm-linux-androideabi\4.9.x\"?

[Yes] [Cancel] [Yes to All]

jmpessoa

  • Hero Member
  • *****
  • Posts: 1111
Re: Android Module Wizard
« Reply #1040 on: May 17, 2018, 06:57:12 pm »

Hi m4u!

The wizard is trying fix your system path...

What happens if you choose [YES]?
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

m4u_hoahoctro

  • Full Member
  • ***
  • Posts: 155
Re: Android Module Wizard
« Reply #1041 on: May 18, 2018, 04:13:45 am »

Hi m4u!

The wizard is trying fix your system path...

What happens if you choose [YES]?

After choosing Yes/Yes to all, everything continues and building apk file starts/lamw GUI project created successfully
but i think something was wrong, right ? . I havent seen this problem before

jmpessoa

  • Hero Member
  • *****
  • Posts: 1111
Re: Android Module Wizard
« Reply #1042 on: May 18, 2018, 08:36:44 am »

Hi m4u!

Go to folder  "Lazarus\config"

and open the file: "JNIAndroidProject.ini"

try change the line:

PrebuildOSYS=windows

to:

PrebuildOSYS=windows-x86_64
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

m4u_hoahoctro

  • Full Member
  • ***
  • Posts: 155
Re: Android Module Wizard
« Reply #1043 on: May 18, 2018, 04:27:15 pm »

Hi m4u!

Go to folder  "Lazarus\config"

and open the file: "JNIAndroidProject.ini"

try change the line:

PrebuildOSYS=windows

to:

PrebuildOSYS=windows-x86_64

Thanks
About your example apps crashes when starts ( projects dont use compat theme or relatives ), do you have somefix ?  :)
And is there some way to implement Admob into my app ?  :)

jmpessoa

  • Hero Member
  • *****
  • Posts: 1111
Re: Android Module Wizard
« Reply #1044 on: May 18, 2018, 07:10:09 pm »


Quote
About your example apps crashes when starts ( projects dont use compat theme or relatives ), do you have somefix ?  :)

What example?

Quote
And is there some way to implement Admob into my app ?

Ok. I will try add/implement Admod support....
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

m4u_hoahoctro

  • Full Member
  • ***
  • Posts: 155
Re: Android Module Wizard
« Reply #1045 on: May 19, 2018, 03:35:45 am »


Quote
About your example apps crashes when starts ( projects dont use compat theme or relatives ), do you have somefix ?  :)

What example?

Many, I tried build and install examples like Bluetooth Demo, Asynctask Demo,...etc, but when start it on phone, the app crashes
I installed app on another but it still be,
If I build and install demos uses AppCompat Themes (Have New Lamw Icon), they runs well  :(

alexc

  • New member
  • *
  • Posts: 6
Re: Android Module Wizard
« Reply #1046 on: May 22, 2018, 08:58:30 am »
Hello.
It's possible do this code:

Intent installIntent = new Intent(Intent.ACTION_VIEW);
installIntent.setDataAndType(Uri.parse("file:///path_to.apk"),
                    "application/vnd.android.package-archive");


on pascal? May be with jIntentManager, but how?

jmpessoa

  • Hero Member
  • *****
  • Posts: 1111
Re: Android Module Wizard
« Reply #1047 on: May 22, 2018, 09:06:39 am »


You can try some "AppIntentManagerDemos*" 

if necessary I can [try] improve the jIntentManager component!
Lamw: Lazarus Android Module Wizard
https://github.com/jmpessoa/lazandroidmodulewizard

alexc

  • New member
  • *
  • Posts: 6
Re: Android Module Wizard
« Reply #1048 on: May 22, 2018, 09:18:22 am »
I tryed the Demos.
But app is crashes.
maybe I'm doing something wrong.

alexc

  • New member
  • *
  • Posts: 6
Re: Android Module Wizard
« Reply #1049 on: May 22, 2018, 11:53:28 am »
Is there any way how to install(update)  the same application what is running, from apk file (downloaded erly)? I mean programmatically.


If I do
jIntentManager1.SetAction('android.intent.action.VIEW');
jIntentManager1.SetDataUri(jIntentManager1.ParseUri('file:///path_to_apk'));
jIntentManager1.StartActivity();

I got mesage "Cannot display PDF"

P.S.
It seems I found where the problem is. The problem is that jIntentManager1 have two procedures "SetDataUri" and "SetMimeType", but don't have procedure (java  method) SetDataAndType.
More info is here: https://stackoverflow.com/questions/13719471/why-setdataandtype-for-an-android-intent-works-fine-when-setdata-and-settype
« Last Edit: May 22, 2018, 01:26:11 pm by alexc »

 

Recent

Get Lazarus at SourceForge.net. Fast, secure and Free Open Source software downloads Open Hub project report for Lazarus