Recent

Author Topic: Fpcupdeluxe  (Read 301525 times)

kevin.black

  • Jr. Member
  • **
  • Posts: 64
Re: Fpcupdeluxe
« Reply #1125 on: February 06, 2019, 03:05:56 am »
So did the install again from clean folders etc. Same error, FPC seems to install, but Lazarus cannot install because cannot find libiconv (liconv not found). It sees to me (and not an expert), but there is an issue with Mojave and the Lazarus install WRT iconv. Note the Fixes/Fixes and the Trunk/Trunk installed on High Sierra (the trunk/trunk required Mojave to run which is why I went there in the first place).

Not sure of the relevance, but here is another issue WRT PHP and iconv:

https://bugs.php.net/bug.php?id=77011

The gist is this:
Quote
I researched the reason and I found that shared libraries bundled Mojave have strange extensions, `.tbd`.

So I am at a loss?

Akira1364

  • Sr. Member
  • ****
  • Posts: 412
Re: Fpcupdeluxe
« Reply #1126 on: February 06, 2019, 03:50:52 am »
The first one is more relevant perhaps, that is to say the:

Code: [Select]
ls /usr/lib/libiconv.*
one.

What he meant was just type that command into your terminal and see what it says.
« Last Edit: February 06, 2019, 03:57:47 am by Akira1364 »

kevin.black

  • Jr. Member
  • **
  • Posts: 64
Re: Fpcupdeluxe
« Reply #1127 on: February 06, 2019, 05:11:33 am »
I've installed Xcode Commandline tools which (I thought) were installed prior to the upgrade from High Sierra to Mojave. For High Sierra a Trunk/Trunk and fixes/fixes install worked. Upgrade to Mojave Doesn't work.

Now, after the install of Xcode command line tools, DOES INDEED WORK.
Code: Pascal  [Select]
  1. SUCCESS: Fpcupdeluxe ended without errors.
  2.  
  3. Fpcupdeluxe has created a shortcut link in your home-directory to start Lazarus.
  4. Shortcut-link: Lazarus_fixes
  5. Lazarus MUST be started with this link !!
  6. Fpcupdeluxe has also (tried to) create a desktop shortcut with the same name.
So that was my bad. Given that the install worked on High Sierra, I assumed that all of the necessary bits and pieces would remain installed when upgrading to Mojave. Not so.

To all those that have responded and offered advice, thanks you, apologies for the time taken, I have no doubt I will be asking for assistance in the future.

Kevin

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1053
Re: Fpcupdeluxe
« Reply #1128 on: February 06, 2019, 08:19:55 am »
Fpcupdeluxe 1.6.2l has been released.
Lazarus stable will now be Lazarus 2.0.0

Please use a new install-directory for this stable, due to the different URL for the previous stable Lazarus 1.8.4 (otherwise, fpcupdeluxe will try to perform an URL svn-switch and that may cause errors).

@kevin.black
Thanks for your feedback !

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1053
Re: Fpcupdeluxe
« Reply #1129 on: February 06, 2019, 10:55:02 am »
There was a bug in v1.6.2l of fpcupdeluxe that prevented https downloads on some systems.
Please use the new latest release (at this moment 1.6.2m) for new installs !

MISV

  • Hero Member
  • *****
  • Posts: 522
Re: Fpcupdeluxe
« Reply #1130 on: February 06, 2019, 11:06:20 am »
I just downloaded trunk today. When staring Lazarus I get error

Error: the Fppkg configuration is corrupt.

Warning: Free Pascal compiler prefix is not a directory

...

Not found a way to solve that issue

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1053
Re: Fpcupdeluxe
« Reply #1131 on: February 06, 2019, 11:18:47 am »
Yep. Getting the same.
Lazarus searches for FPC directories that can be found in the path or are standard for normal installs.

When you start Lazarus, you will get a dialog that allows you to select a fppkg directory. You must point it towards the FPC install directory.
On Windows, this can be:
C:\fpcupdeluxe\fpc
In normal (other cases) cases:
your_install_dir/fpc
Then use the button to create the fppkg configs.

Still looking into a better solution however.

MISV

  • Hero Member
  • *****
  • Posts: 522
Re: Fpcupdeluxe
« Reply #1132 on: February 06, 2019, 11:55:09 am »
1)
I am on Mac.

The "stable" in FPCDeluxe works, but trunk gives the following problem:

2)
The dialog opens and initially it is configured to
/usr/local

Quote
Error: the Fppkg configuration is corrupt

3)
I point to where fpcdeluxe installed: /Users/myname/myinstall/fpc

Quote
Erorr: the Fppkg configuration is corrupt

4)
I click "Create new Fppkg configuration

Error-MessageBox:
Quote
Problem with FPPkg configuration
Failed to create a new fppkg configuration. You will have to fix the configuration manually or reinstall Free Pascal

5)
I am stuck - seems the FPC installation of FPCDeluze no longer works. Will it help to download FPC manually?

The problem for me is I need to test FPC trunk since it seems there is a problem in FPC so Mac apps no longer will run on anything older than 1.14 - see this post: https://forum.lazarus.freepascal.org/index.php/topic,44159.0.html
« Last Edit: February 06, 2019, 12:51:27 pm by MISV »

xaver13

  • Jr. Member
  • **
  • Posts: 92
Re: Fpcupdeluxe
« Reply #1133 on: February 06, 2019, 02:14:16 pm »
Tomorrow !  ;)

Thank you very much Caballero :)
--
Jiri Cvrk

BSaidus

  • Sr. Member
  • ****
  • Posts: 265
  • lazarus 1.8.4 Win8.1 / cross FreeBSD
Re: Fpcupdeluxe
« Reply #1134 on: February 06, 2019, 08:30:09 pm »
Thanks Don Alfredo for your work.
Can I install Lazarus 2.0 release with FPC from newpascal ??

When you plane to release a new version of newpascal ??

Thnks:::)
lazarus 1.8.4 Win8.1 / cross FreeBSD
dhukmucmur vernadh!

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1053
Re: Fpcupdeluxe
« Reply #1135 on: February 07, 2019, 09:32:07 am »
@BSaidus
NewPascal is no longer maintained unfortunately.
Quote
Can I install Lazarus 2.0 release with FPC from newpascal ??
That does not work anymore.

@MISV
I cannot reproduce anymore.
On my Mac 10.14 everything works as expected.
The fppkg-settings are hidden somewhere I cannot find them.
Still hoping for more information from the developers.

BSaidus

  • Sr. Member
  • ****
  • Posts: 265
  • lazarus 1.8.4 Win8.1 / cross FreeBSD
Re: Fpcupdeluxe
« Reply #1136 on: February 07, 2019, 05:49:28 pm »
@DonAlfredo
Quote
@BSaidus
NewPascal is no longer maintained unfortunately.
what version of compiler and IDE you recommand me to compile mORMot ??

Thanks.
lazarus 1.8.4 Win8.1 / cross FreeBSD
dhukmucmur vernadh!

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1053
Re: Fpcupdeluxe
« Reply #1137 on: February 07, 2019, 06:53:38 pm »
FPC fixes 3.2
or
FPC trunk

Both have the extra RTTI that is needed.

And a fitting Lazarus (fixes 2.0 or trunk).
(mORMot only needs FPC)

BSaidus

  • Sr. Member
  • ****
  • Posts: 265
  • lazarus 1.8.4 Win8.1 / cross FreeBSD
Re: Fpcupdeluxe
« Reply #1138 on: February 07, 2019, 08:10:46 pm »
FPC fixes 3.2
or
FPC trunk

Both have the extra RTTI that is needed.

And a fitting Lazarus (fixes 2.0 or trunk).
(mORMot only needs FPC)


thanks  :)
lazarus 1.8.4 Win8.1 / cross FreeBSD
dhukmucmur vernadh!

mercurhyo

  • Jr. Member
  • **
  • Posts: 90
Re: Fpcupdeluxe
« Reply #1139 on: February 09, 2019, 11:15:18 am »
Helper repport =>
Windows 7 64 bits :
last working version of fpcupdeluxe is 1.6.2.h

newest versions enter an infinite loop while "checking for update" at startup.

both with the binary I got from the release server, and the oneS I compiled from sources with Laz 2.0RC3

then I click many times to close the main UI and exit the application, it hangs. I must open windows taskmanager and force fpcupdeluxe process to stop manually
DEO MERCHVRIO - Linux Mint latest, Windows 7 - Laz latest fixes- RAD Studio XE7
god of financial gain, commerce, eloquence (and thus poetry), messages, communication (including divination), travelers, boundaries, luck, trickery and thieves; he also serves as the guide of souls to the underworld