Recent

Author Topic: Fpcupdeluxe  (Read 301536 times)

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1053
Re: Fpcupdeluxe
« Reply #1140 on: February 09, 2019, 11:19:53 am »
@mercurhyo
Did you try the latest version: 1.6.2m ?

mercurhyo

  • Jr. Member
  • **
  • Posts: 90
Re: Fpcupdeluxe
« Reply #1141 on: February 09, 2019, 11:22:02 am »
yep sir, just yesterday
DEO MERCHVRIO - Linux Mint latest, Windows 7 - Laz latest fixes- RAD Studio XE7
god of financial gain, commerce, eloquence (and thus poetry), messages, communication (including divination), travelers, boundaries, luck, trickery and thieves; he also serves as the guide of souls to the underworld

mercurhyo

  • Jr. Member
  • **
  • Posts: 90
Re: Fpcupdeluxe
« Reply #1142 on: February 09, 2019, 11:25:35 am »
oh I forgot to mention I am running win 7 64 bits BUT I do use fpcupdeluxe-win32 ... It might matter
DEO MERCHVRIO - Linux Mint latest, Windows 7 - Laz latest fixes- RAD Studio XE7
god of financial gain, commerce, eloquence (and thus poetry), messages, communication (including divination), travelers, boundaries, luck, trickery and thieves; he also serves as the guide of souls to the underworld

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1053
Re: Fpcupdeluxe
« Reply #1143 on: February 09, 2019, 11:36:02 am »
Would you mind testing a pre-release.
Check update is now an option that is disabled by default.

https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/tag/1.6.2n

mercurhyo

  • Jr. Member
  • **
  • Posts: 90
Re: Fpcupdeluxe
« Reply #1144 on: February 09, 2019, 11:40:18 am »
on the way... standby
DEO MERCHVRIO - Linux Mint latest, Windows 7 - Laz latest fixes- RAD Studio XE7
god of financial gain, commerce, eloquence (and thus poetry), messages, communication (including divination), travelers, boundaries, luck, trickery and thieves; he also serves as the guide of souls to the underworld

mercurhyo

  • Jr. Member
  • **
  • Posts: 90
Re: Fpcupdeluxe
« Reply #1145 on: February 09, 2019, 11:43:15 am »
ok 1.6.2.n win32 opens and close fairly, thanks.
I will run an entire build in the day, and let you know if any problem. Otherwise, consider that I am happy with, if I don't talk
Regards
DEO MERCHVRIO - Linux Mint latest, Windows 7 - Laz latest fixes- RAD Studio XE7
god of financial gain, commerce, eloquence (and thus poetry), messages, communication (including divination), travelers, boundaries, luck, trickery and thieves; he also serves as the guide of souls to the underworld

avra

  • Hero Member
  • *****
  • Posts: 1443
    • Additional info
Re: Fpcupdeluxe
« Reply #1146 on: February 11, 2019, 12:23:19 pm »
I have noticed that FPCUPDELUXE synapse package is missing inclusion of ssl_openssl unit in lpk file. OPM version includes this file properly.

There is also a problem when I first install OPM Synapse. After that when I install some FPCUPDELUXE ccr package which needs Synapse, FPCUPDELUXE install installs it's own Synapse besides OPM Synapse, and I have to fix things by hand (leaving only OPM version and recompiling IDE).

Can FPCUPDELUXE check if Synapse already exists so it does not install yet another one? From what I see both FPCUPDELUXE and OPM have same package name for Synapse.

Thanks for your hard work!
ct2laz - Conversion between Lazarus and CodeTyphon
bithelpers - Bit manipulation for standard types
pasettimino - Siemens S7 PLC lib

sstvmaster

  • New member
  • *
  • Posts: 35
Re: Fpcupdeluxe
« Reply #1147 on: February 11, 2019, 12:46:25 pm »
if you have problems with fpcupdeluxe under Windows 7, look here for possible solution.

https://forum.lazarus.freepascal.org/index.php/topic,44235.0.html
Lazarus 2.0.0 x32
Lazarus 2.1.0 Trunk x32
OS Win 7 32bit

DonAlfredo

  • Hero Member
  • *****
  • Posts: 1053
Re: Fpcupdeluxe
« Reply #1148 on: February 11, 2019, 01:39:47 pm »
@avra
You detected a serious conflict between OPM and fpcupdeluxe ...  ;)
And a conflict that is not easy to solve.
It will require that fpcupdeluxe has to detect which packages are already installed by others.

Will look into it, but without promisses.

@sstvmaster
The latest fpcupdeluxe version should solve problems on Win7 and older without the need of installing PowerShell. I have added BitsAdmin as a downloader.

avra

  • Hero Member
  • *****
  • Posts: 1443
    • Additional info
Re: Fpcupdeluxe
« Reply #1149 on: February 11, 2019, 02:13:45 pm »
You detected a serious conflict between OPM and fpcupdeluxe ...  ;)
And a conflict that is not easy to solve.
It will require that fpcupdeluxe has to detect which packages are already installed by others.
Yes, in a generic way that would be time consuming and not easy at all. But for just synapse it would not be that hard, since you know in what dir to expect OPM's Synapse.

For other packages I can simply choose either OPM or FPCUPDELUXE versions and avoid confusion completely, but for Synapse there is nothing I can do to avoid such double installation since I install a package that depends on Synapse.

Quote
Will look into it, but without promisses.
Don't worry. I understand priorities and I can live with manual fixing.
ct2laz - Conversion between Lazarus and CodeTyphon
bithelpers - Bit manipulation for standard types
pasettimino - Siemens S7 PLC lib

sstvmaster

  • New member
  • *
  • Posts: 35
Re: Fpcupdeluxe
« Reply #1150 on: February 11, 2019, 02:17:20 pm »
@sstvmaster
The latest fpcupdeluxe version should solve problems on Win7 and older without the need of installing PowerShell. I have added BitsAdmin as a downloader.

Ok, thank you!
Lazarus 2.0.0 x32
Lazarus 2.1.0 Trunk x32
OS Win 7 32bit

ertank

  • Full Member
  • ***
  • Posts: 234
Re: Fpcupdeluxe
« Reply #1151 on: February 11, 2019, 08:43:56 pm »
I have a problem checking out Indy SVN repository using fpcupdeluxe. Below is partial log file.
Code: [Select]
FPCUPdeluxe V1.6.2l for arm-linux-gtk2

Limiting installation/update to indy

Going to install selected modules with given options.
FPCUP(deluxe) is starting up.

Bootstrap dir:         /home/pi/fpcupdeluxe/fpcbootstrap
FPC URL:               https://svn.freepascal.org/svn/fpc/branches/fixes_3_2
FPC options:           
FPC source directory:  /home/pi/fpcupdeluxe/fpcsrc
FPC install directory: /home/pi/fpcupdeluxe/fpc
Lazarus URL:           https://svn.freepascal.org/svn/lazarus/branches/fixes_2_0
Lazarus options:       
Lazarus directory:     /home/pi/fpcupdeluxe/lazarus

Please stand back and enjoy !

fpcupdeluxe: info: 11-2-19 22:35:56: fpcupdeluxe: V071 (20190206) started.
fpcupdeluxe: info: UniversalInstaller (GetModule: indy): Getting module indy
fpcupdeluxe: info: UniversalInstaller (GetModule: indy): Going to download/update from SVN repository https://svn.atozed.com:444/svn/Indy10/trunk/
fpcupdeluxe: info: UniversalInstaller (GetModule: indy): Please wait: this can take some time (if repo is big or has a large history).
fpcupdeluxe: info: Directory /home/pi/fpcupdeluxe/ccr/indy is not an SVN repository (or a repository with the wrong remote URL).
Executing: /usr/bin/svn info 'https://svn.atozed.com:444/svn/Indy10/trunk/' (working dir: )
svn: E170013: Unable to connect to a repository at URL 'https://svn.atozed.com:444/svn/Indy10/trunk'
svn: E215004: No more credentials or we tried too many times.
Authentication failed
fpcupdeluxe: info: UniversalInstaller (DownloadFromSVN: indy): Running SVN checkout or update.
Executing: /usr/bin/svn info 'https://svn.atozed.com:444/svn/Indy10/trunk/' (working dir: )
svn: E170013: Unable to connect to a repository at URL 'https://svn.atozed.com:444/svn/Indy10/trunk'
svn: E215004: No more credentials or we tried too many times.
Authentication failed
Executing: /usr/bin/svn info 'https://svn.atozed.com:444/svn/Indy10/trunk/' (working dir: )
svn: E170013: Unable to connect to a repository at URL 'https://svn.atozed.com:444/svn/Indy10/trunk'
svn: E215004: No more credentials or we tried too many times.
Authentication failed
fpcupdeluxe: info: UniversalInstaller (GetModule: indy): Download/update from SVN repository ok.
fpcupdeluxe: info: UniversalInstaller (BuildModule: indy): Building module indy...

When I try to manually checkout, svn warns me of certificate is not from a trusted source or something. I accept certificate permanently. Then I am asked for username and password for that repository.

Above log is after I do all there on command line manually.

Thanks & regards,
Ertan

josh

  • Hero Member
  • *****
  • Posts: 719
Re: Fpcupdeluxe
« Reply #1152 on: February 13, 2019, 03:08:58 am »
Unable to install trunk on fresh windows 7 install.

It is stuck on message, cannot find OpenSSL libraries, going to download. 

Its been there for 40 minutes.....

is there a special way?
Development Installation Lazarus 1.3, FPC 2.7.1,Windows 7/8 32/64, OSX, *nix

Test Environment Lazarus & FPC Trunk on Windows and OSX (Cocoa Mainly on OSX). Testing also Crosscompile windows to OSX.. 
Any posts made from 2015 will be based on Lazarus Trunk.

avra

  • Hero Member
  • *****
  • Posts: 1443
    • Additional info
Re: Fpcupdeluxe
« Reply #1153 on: February 13, 2019, 08:13:08 am »
is there a special way?
Try to put libeay32.dll and ssleay32.dll from some other fpcupdeluxe dir into dir where new fpcupdeluxe-i386-win32.exe is, and then start fpcupdeluxe-i386-win32.exe again.
ct2laz - Conversion between Lazarus and CodeTyphon
bithelpers - Bit manipulation for standard types
pasettimino - Siemens S7 PLC lib

kevin.black

  • Jr. Member
  • **
  • Posts: 64
Re: Fpcupdeluxe
« Reply #1154 on: February 13, 2019, 11:28:13 pm »
MOJAVE: This may be nothing, but I am being told there is a new version of fpcupdeluxe:
Code: Pascal  [Select]
  1. Please wait. Checking for updates.
  2. New fpcupdeluxe version available
  3. https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/latest
  4. https://github.com/LongDirtyAnimAlf/fpcupdeluxe/releases/download/v1.6.2m/fpcupdeluxe-x86_64-darwin-cocoa.zip
When I go and download the zip file (fpcupdeluxe-x86_64-darwin-cocoa.zip) from either of those locations the zip file downloaded is time stamped 01 Oct 2018 at 10:07?

Am I looking in the wrong place, or is this just an aberration?

BUT MORE IMPORTANTLY:

Has anyone resolved the issue reported by @MISV on 6 Feb (and if so, how to get around it)?

4)
I click "Create new Fppkg configuration

Error-MessageBox:
Quote
Problem with FPPkg configuration
Failed to create a new fppkg configuration. You will have to fix the configuration manually or reinstall Free Pascal

5)
I am stuck - seems the FPC installation of FPCDeluze no longer works. Will it help to download FPC manually?

The problem for me is I need to test FPC trunk since it seems there is a problem in FPC so Mac apps no longer will run on anything older than 1.14 - see this post: https://forum.lazarus.freepascal.org/index.php/topic,44159.0.html

Suggested Solution:

When you start Lazarus, you will get a dialog that allows you to select a fppkg directory. You must point it towards the FPC install directory.
On Windows, this can be:
C:\fpcupdeluxe\fpc
In normal (other cases) cases:
your_install_dir/fpc
Then use the button to create the fppkg configs.   <<<<=====THIS DOES NOT WORK ERROR: PROBLEM WITH FPPKG CONFIGURATION ETC ETC

I have this error and I point to the correct Folder (in my case: ../fpcupdeluxe/fixes/fpc and I get exactly the same error: Problem with fppkg configuration etc etc, the suggested workaround does not work...

Based on advice, I installed FPC Fixes3.2 / Lazarus Trunk. The installation was fine, I just cannot get past this error on startup.

When finding a corrupt FPPKG folder and not being able to create a new one, the suggestion is to 'Fix it manually'. I have no idea how to even start doing that?

EDIT:

Did a complete clean install to a clean folder of Trunk/Trunk and EXACTLY the same result.

Is this possibly a MOJAVE thing? I don't see a lot of non-macOS complaints (BTW, set the permissions to everyone:Read/Write) from the fpcipdeluxe root folder)

EDIT EDIT:

I'm going insane. I was getting somewhat disappointed and depressed so went to the pharmacy (just to get some standard meds nothing drastic) and came back . I now run both versions of installed lazarus and WTF they both run as expected ie. normally nothing abut FPPKG errors etc etc. I'm sorry, I cannot explain it, I did NOTHING and I don't mean I did nothing out of the ordinary, I mean I did absolutely nothing. I could try another install, try to run lazarus and if it fails wait an hour or two, meh... This is working now. Regardless, I still think (OSX Mojave) there is an issue, after installing fpcupdeluxe whatever versions, with fppkg. Is there/are there any log files I can send to those in the know so that they might get a better feel for the problems, happy to do that?

Kevin
« Last Edit: February 14, 2019, 04:53:40 am by kevin.black »