Recent

Author Topic: Unable to build IDE with Lnet  (Read 693 times)

muonman

  • New member
  • *
  • Posts: 6
Unable to build IDE with Lnet
« on: November 23, 2018, 11:55:28 am »
I have installed 1.8.4 together with fpc 3.0.4 and all was well.
Successfully  rebuilt on installing lcl but when rebuilding to install lnet have come up against a brick wall.

Fatal: Cannot find sslsockets used by fphttpclient. Make sure all ppu files of a package are in its output directory. ppu in wrong directory=/usr/lib/fpc/3.0.4/units/x86_64-linux/fcl-net/sslsockets.ppu

I may be dumb but the file is clearly known to the system and I have copied it to various other paths so it cannot be missed. I am running Ubuntu 18.04.1

Any explanation and escape route would be appreciated.

RastaManKing

  • New member
  • *
  • Posts: 13
Re: Unable to build IDE with Lnet
« Reply #1 on: November 30, 2018, 11:57:42 am »
im also interested on this...  %)

Thaddy

  • Hero Member
  • *****
  • Posts: 7182
Re: Unable to build IDE with Lnet
« Reply #2 on: November 30, 2018, 12:31:36 pm »
First of all: you are not dumb!
You provided complete information.
Ubuntu 18 is a serious problem for many of us, although for some reason I never experienced it.
There are some - good - instructions available by other forum members, specifically Handoko (ignore my comments) but it seems highly CPU specific.

Probably Handoko will respond with a closer answer.
« Last Edit: November 30, 2018, 12:39:10 pm by Thaddy »
inline variables like in D10.3 are a bit like Brexit: if you are given the wrong information it sounds like a good idea. Every kid loves candy, but it makes you fat and your teeth will disappear.

RastaManKing

  • New member
  • *
  • Posts: 13
Re: Unable to build IDE with Lnet
« Reply #3 on: December 02, 2018, 11:09:31 am »
I have installed 1.8.4 together with fpc 3.0.4 and all was well.
Successfully  rebuilt on installing lcl but when rebuilding to install lnet have come up against a brick wall.

Fatal: Cannot find sslsockets used by fphttpclient. Make sure all ppu files of a package are in its output directory. ppu in wrong directory=/usr/lib/fpc/3.0.4/units/x86_64-linux/fcl-net/sslsockets.ppu

I may be dumb but the file is clearly known to the system and I have copied it to various other paths so it cannot be missed. I am running Ubuntu 18.04.1

Any explanation and escape route would be appreciated.

Im using Arch Linux, and i was having the same problem, but i was able to install the package from the online package manager, you should try installing lnet package from the onlinepackagemanager.pkg

Handoko

  • Hero Member
  • *****
  • Posts: 2684
  • My goal: build my own game engine using Lazarus
Re: Unable to build IDE with Lnet
« Reply #4 on: December 02, 2018, 12:18:54 pm »
I have no problem installing LNET on my Lazarus 1.8.4 FPC 3.0.4 Ubuntu 18.10 using Online Package Manager.