Recent

Author Topic: Installing on Raspberry Pi3 B+  (Read 115 times)

jasc2v8

  • New member
  • *
  • Posts: 37
Installing on Raspberry Pi3 B+
« on: December 07, 2018, 04:05:47 pm »
Installed fpc-3.0.4 / lazarus-1.8.4, but cannot install AnchorDockingDsgn.
Get error 'Cannot find anchordockingdsgn used by Lazarus'.
Same issue trying to install other packages.

I'm rather ignorant with Linux so help is appreciated.
I read other posts but do not understand how this was resolved.
I tried sudo chmod a+rwx /usr/lib/lazarus -R but did not resolve the error.

Installed using instructions from several posts by Thaddy as follows:

  1. Add stretch-backports to sources.list

   Create:   /etc/apt/sources.list.d/backports.list
   Add:      deb http://ftp.debian.org/debian stretch-backports main
   Update:   sudo apt-get update

2.  FPC 3.0.4 and Lazarus 1.8.4 are both in stretch-backports
     Use apt or apt-get, need to install with the -t option.
     Answer Y to install without verification.
   
   sudo apt-get -t stretch-backports install "fpc-3.0.4"
   sudo apt-get -t stretch-backports install "lazarus-1.8"