Recent

Author Topic: Raspbian FPC 3.3.1 and Lazarus 2.0 Available  (Read 523 times)

sysrpl

  • Full Member
  • ***
  • Posts: 219
Raspbian FPC 3.3.1 and Lazarus 2.0 Available
« on: February 11, 2019, 03:23:52 pm »
I've made available precompiled bundles of FPC 3.3.1 and Lazarus 2.0 for the Raspberry Pi. You can download this bundle at this location:

https://www.getlazarus.org/setup/?download#raspberry_pi

This Raspbian bundle is much larger than my previous bundle weighing in at 635MB compared to the previous version's 200MB. The increase in almost entirely size is due to the inclusion of many more FPC packages. If any of you feel that a reduced install size is more important, please let me know and I'll consider removing the same packages which were removed in the previous bundle.

Please note, if you are trying to run Lazarus 2.0 on Raspbian and want to rebuild the IDE you'll need at least a 512MB swap file size. Please see the Raspbian documentation on how to enable and manage your Raspbian swap file.
« Last Edit: February 11, 2019, 03:30:48 pm by sysrpl »

af0815

  • Full Member
  • ***
  • Posts: 221
Re: Raspbian FPC 3.3.1 and Lazarus 2.0 Available
« Reply #1 on: February 11, 2019, 04:41:41 pm »
512 is only enough for a very lean and naked Lazarus to recompile.1 to 2 GB swap is ok. With a RasPi 3B+ you can work very good and debug.

regards
Andreas

Thaddy

  • Hero Member
  • *****
  • Posts: 7457
Re: Raspbian FPC 3.3.1 and Lazarus 2.0 Available
« Reply #2 on: February 11, 2019, 08:25:04 pm »
512 is only enough for a very lean and naked Lazarus to recompile.1 to 2 GB swap is ok. With a RasPi 3B+ you can work very good and debug.
No, provided there is a swap file about the size of internal memory there is no problem compiling fpc and Lazarus natively. Even on a RPi 1b.
Ad Brexinitum (can't help it)

Prof-H

  • Newbie
  • Posts: 2
Re: Raspbian FPC 3.3.1 and Lazarus 2.0 Available
« Reply #3 on: February 13, 2019, 07:31:21 pm »
Help new to Lazarus
Downloded FPC 3.3.1 and Lazarus 2.0 for the Raspberry Pi using your installer.
but get this error

(clipbrd.pp(120,22) Fatal: Cannot find fasthtmlparser used by Clipbrd of package LCLBase.)

I have not added any controls of code, just compiling a blank form to test installation.

fpc chm package is missing!
« Last Edit: February 14, 2019, 03:26:14 am by Prof-H »