Recent

Author Topic: [BUG] Cannot Create Package [Windows 64, Lazarus 2.0]  (Read 637 times)

HuntingKashket

  • New member
  • *
  • Posts: 16
  • I'm not a quitely obsessed
[BUG] Cannot Create Package [Windows 64, Lazarus 2.0]
« on: March 13, 2019, 01:32:30 pm »
When trying to create a package (doesn't matter from which place), i see 'Division by zero' error
Lazarus IDE:
IDE is displaying in docked mode (sparta_DockedFormEditor and AnchorDockingDsgn installed)
Win32 extension is installed

Screenshot and package list is attached

Configuration:
Intel Celeron n3060 (@1.6Ghz)
RAM 4Gb (1777Mhz, working in 800mhz mode)
Windows 8.1 Pro [x64] with latest updates

Package list
Code: XML  [Select]
  1. <?xml version="1.0" encoding="UTF-8"?>
  2. <CONFIG>
  3.   <Packages Count="52">
  4.     <Item0 ID="FCL 1.0.1"/>
  5.     <Item1 ID="LazUtils 1.0"/>
  6.     <Item2 ID="CodeTools 1.0.1"/>
  7.     <Item3 ID="LCLBase 2.0.0.3"/>
  8.     <Item4 ID="DateTimeCtrls 1.5.1"/>
  9.     <Item5 ID="CmdLineDebuggerBase 0.0"/>
  10.     <Item6 ID="DebuggerIntf 0.1"/>
  11.     <Item7 ID="LCL 2.0.0.3"/>
  12.     <Item8 ID="ImagesForLazarus 1.0.1"/>
  13.     <Item9 ID="pascalscript 0.0.0.1"/>
  14.     <Item10 ID="SDFLaz 0.1.1"/>
  15.     <Item11 ID="lazmrumenu 1.0"/>
  16.     <Item12 ID="LazOpenGLContext 0.0.1"/>
  17.     <Item13 ID="CEF4Delphi_Lazarus 1.0"/>
  18.     <Item14 ID="LazControls 1.0.1"/>
  19.     <Item15 ID="SynEdit 1.0"/>
  20.     <Item16 ID="fpvectorial2aggpaspkg 0.0"/>
  21.     <Item17 ID="LazDebuggerFpLldb 0.0"/>
  22.     <Item18 ID="Printer4Lazarus 0.5"/>
  23.     <Item19 ID="IDEIntf 1.0"/>
  24.     <Item20 ID="SynUni 1.0"/>
  25.     <Item21 ID="LazC 0.1"/>
  26.     <Item22 ID="LazActiveX 0.1"/>
  27.     <Item23 ID="customdrawn 0.0"/>
  28.     <Item24 ID="AnchorDockingDsgn 1.0"/>
  29.     <Item25 ID="EditorMacroScript 0.0"/>
  30.     <Item26 ID="DBFLaz 0.1.1"/>
  31.     <Item27 ID="SQLDBLaz 1.0.2"/>
  32.     <Item28 ID="ToDoListLaz 1.0.2"/>
  33.     <Item29 ID="TAChartLazarusPkg 1.0"/>
  34.     <Item30 ID="ProjTemplates 1.0"/>
  35.     <Item31 ID="fpcunitide 0.1"/>
  36.     <Item32 ID="ChmHelpPkg 0.2"/>
  37.     <Item33 ID="jcfidelazarus 2.0"/>
  38.     <Item34 ID="TurboPowerIPro 1.0"/>
  39.     <Item35 ID="ExternHelp 1.3"/>
  40.     <Item36 ID="InstantFPCLaz 1.0"/>
  41.     <Item37 ID="MemDSLaz 1.2.1"/>
  42.     <Item38 ID="leakview 1.0"/>
  43.     <Item39 ID="printers4lazide 0.0"/>
  44.     <Item40 ID="RunTimeTypeInfoControls 0.1"/>
  45.     <Item41 ID="DateTimeCtrlsDsgn 1.5.1"/>
  46.     <Item42 ID="LazControlDsgn 0.0"/>
  47.     <Item43 ID="SynEditDsgn 1.0"/>
  48.     <Item44 ID="idefilebrowser 0.2"/>
  49.     <Item45 ID="lazdaemon 0.9.9"/>
  50.     <Item46 ID="QuickFixExample 0.0"/>
  51.     <Item47 ID="sparta_DockedFormEditor 0.0"/>
  52.     <Item48 ID="LazDebuggerGdbmi 0.1"/>
  53.     <Item49 ID="TAChartAggPas 1.0"/>
  54.     <Item50 ID="OnlinePackageManager 1.0.1.2"/>
  55.     <Item51 ID="TurboPowerIProDsgn 0.0"/>
  56.   </Packages>
  57. </CONFIG>
  58.  
P.s CEF4Delphi package doesn't change anything about that
« Last Edit: March 17, 2019, 04:15:31 pm by HuntingKashket »
Andew Zenin

HuntingKashket

  • New member
  • *
  • Posts: 16
  • I'm not a quitely obsessed
Re: Cannot Create Package [Windows 64, Lazarus 2.0-RC3]
« Reply #1 on: March 14, 2019, 10:04:20 am »
In case of application conflicts, i have listed all of the installed tools bellow

Adobe Flash Player 32 {NPAPI, PPAPI}
Bitnami WAMP Stack
Boost Libraries for Embarcadero Developer Tools
Embarcadero Interbase XE7
Embarcadero RAD Studio 10.1 Berlin
FastReport5 Embarcadero Edition
Microsoft VisualStudio Express 2012 for Windows Desktop - RUS
Git v2.17.1.2
Entity Framework Designer for VS2012
FileZilla FTP Client 3.41.1
HashTab 6.0.0.34
HHPMod
HTML Help Workshop
HxD Hex Editor 2.2.1
Java SE Development Kit 8 Update 181 {32, 64}-bit
JPEXS Free Flash Decompiler
Microsoft .NET Compact Framework 3.5
Microsoft .NET Core SDK - 2.1.202(x64)
Microsoft .NET Core SDK 2.1.402(x64)
Microsoft .NET Framework 4.5 Multi-Targeting Pack
Microsoft .NET Framework 4.5 SDK
Microsoft .NET Framework 4.5 russian localization
Microsoft DirectX SDK (March 2008)
Microsoft Games for Windows - LIVE Redistributable
Microsoft Help Viewer 2.0
Microsoft Identity Extensions (<== i don't know where it come from)
Microsoft {Office, Project, Visio} 2016
Microsoft Visual C++ 2005 Redistributable - x64 8.0.61000
Microsoft Visual C++ 2005 Redistributable - x86 8.0.61001
Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.6161
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.6161
Microsoft Visual C++ 2010 Redistributable - x64 10.0.40219
Microsoft Visual C++ 2010 Redistributable - x86 10.0.40219
Microsoft Visual C++ 2012 Redistributable (x64) - 11.0.61030
Microsoft Visual C++ 2012 Redistributable (x86) - 11.0.61030
Microsoft Visual C++ 2013 Redistributable (x64) - 12.0.40664
Microsoft Visual C++ 2013 Redistributable (x86) - 12.0.40664
Microsoft Visual C++ 2017 Redistributable (x64) - 14.15.26706
Microsoft Visual C++ 2017 Redistributable (x86) - 14.15.26706
Microsoft Visual Studio 2010 Tools for Office Runtime (x64)
[(i'm not sure which program installed 2010 tools, but i haven't installed MSVS2010)]
Notepad++ (32-bit x86)
Nvidia PhysX
OpenAL
OpenIV (GTA 3, 4, 5 and EFLC mods creation panel)
Orca
qBittorent [(it depends on qt framework)]
Resource Hacker Version 5.1.6
Steam
TortoiseSVN 1.11.1.28492 (64 bit)
Visual Studio Extensions for Windows Library for JavaScript 2.1.30324.52 [php won't compile without it]
WinRAR 5.60 (64-bit)
Языковой пакет для средства просмотра справки (Language package for help viewing service (Microsoft) 2.0 - RUS)
« Last Edit: March 14, 2019, 04:49:27 pm by HuntingKashket »
Andew Zenin

Cyrax

  • Hero Member
  • *****
  • Posts: 697
Re: Cannot Create Package [Windows 64, Lazarus 2.0-RC3]
« Reply #2 on: March 14, 2019, 10:15:05 am »
Please test the release version (Lazarus 2.0.0), not the release candidate (RC). Also try the fixes branch (2.0.x). You can get it by using fpcupdeluxe : https://forum.lazarus.freepascal.org/index.php/topic,34645.0.html

HuntingKashket

  • New member
  • *
  • Posts: 16
  • I'm not a quitely obsessed
Re: Cannot Create Package [Windows 64, Lazarus 2.0-RC3]
« Reply #3 on: March 14, 2019, 11:22:15 am »
Please test the release version (Lazarus 2.0.0), not the release candidate (RC). Also try the fixes branch (2.0.x). You can get it by using fpcupdeluxe : https://forum.lazarus.freepascal.org/index.php/topic,34645.0.html
Thanks  :D
Andew Zenin

valdir.marcos

  • Hero Member
  • *****
  • Posts: 650
Re: [SOLVED] Cannot Create Package [Windows 64, Lazarus 2.0-RC3]
« Reply #4 on: March 14, 2019, 03:01:33 pm »
When trying to create a package (doesn't matter from which place), i see 'Division by zero' error
Lazarus IDE:
IDE is displaying in docked mode (sparta_DockedFormEditor and AnchorDockingDsgn installed)
Win32 extension is installed

Screenshot and package list is attached

Configuration:
Intel Celeron n3060 (@1.6Ghz)
RAM 4Gb (1777Mhz, working in 800mhz mode)
If possible, increase your RAM to 8gb or 16gb.

Quote
Windows 8.1 Pro [x64] with latest updates
If possible, format your notebook and install Windows 7 (lighter and faster) or Windows 10 (better option than 8.1 if you have 8gb or more of RAM).

Quote
Package list
Code: XML  [Select]
  1. <?xml version="1.0" encoding="UTF-8"?>
  2. <CONFIG>
  3.   <Packages Count="52">
  4.     <Item0 ID="FCL 1.0.1"/>
  5.     <Item1 ID="LazUtils 1.0"/>
  6.     <Item2 ID="CodeTools 1.0.1"/>
  7.     <Item3 ID="LCLBase 2.0.0.3"/>
  8.     <Item4 ID="DateTimeCtrls 1.5.1"/>
  9.     <Item5 ID="CmdLineDebuggerBase 0.0"/>
  10.     <Item6 ID="DebuggerIntf 0.1"/>
  11.     <Item7 ID="LCL 2.0.0.3"/>
  12.     <Item8 ID="ImagesForLazarus 1.0.1"/>
  13.     <Item9 ID="pascalscript 0.0.0.1"/>
  14.     <Item10 ID="SDFLaz 0.1.1"/>
  15.     <Item11 ID="lazmrumenu 1.0"/>
  16.     <Item12 ID="LazOpenGLContext 0.0.1"/>
  17.     <Item13 ID="CEF4Delphi_Lazarus 1.0"/>
  18.     <Item14 ID="LazControls 1.0.1"/>
  19.     <Item15 ID="SynEdit 1.0"/>
  20.     <Item16 ID="fpvectorial2aggpaspkg 0.0"/>
  21.     <Item17 ID="LazDebuggerFpLldb 0.0"/>
  22.     <Item18 ID="Printer4Lazarus 0.5"/>
  23.     <Item19 ID="IDEIntf 1.0"/>
  24.     <Item20 ID="SynUni 1.0"/>
  25.     <Item21 ID="LazC 0.1"/>
  26.     <Item22 ID="LazActiveX 0.1"/>
  27.     <Item23 ID="customdrawn 0.0"/>
  28.     <Item24 ID="AnchorDockingDsgn 1.0"/>
  29.     <Item25 ID="EditorMacroScript 0.0"/>
  30.     <Item26 ID="DBFLaz 0.1.1"/>
  31.     <Item27 ID="SQLDBLaz 1.0.2"/>
  32.     <Item28 ID="ToDoListLaz 1.0.2"/>
  33.     <Item29 ID="TAChartLazarusPkg 1.0"/>
  34.     <Item30 ID="ProjTemplates 1.0"/>
  35.     <Item31 ID="fpcunitide 0.1"/>
  36.     <Item32 ID="ChmHelpPkg 0.2"/>
  37.     <Item33 ID="jcfidelazarus 2.0"/>
  38.     <Item34 ID="TurboPowerIPro 1.0"/>
  39.     <Item35 ID="ExternHelp 1.3"/>
  40.     <Item36 ID="InstantFPCLaz 1.0"/>
  41.     <Item37 ID="MemDSLaz 1.2.1"/>
  42.     <Item38 ID="leakview 1.0"/>
  43.     <Item39 ID="printers4lazide 0.0"/>
  44.     <Item40 ID="RunTimeTypeInfoControls 0.1"/>
  45.     <Item41 ID="DateTimeCtrlsDsgn 1.5.1"/>
  46.     <Item42 ID="LazControlDsgn 0.0"/>
  47.     <Item43 ID="SynEditDsgn 1.0"/>
  48.     <Item44 ID="idefilebrowser 0.2"/>
  49.     <Item45 ID="lazdaemon 0.9.9"/>
  50.     <Item46 ID="QuickFixExample 0.0"/>
  51.     <Item47 ID="sparta_DockedFormEditor 0.0"/>
  52.     <Item48 ID="LazDebuggerGdbmi 0.1"/>
  53.     <Item49 ID="TAChartAggPas 1.0"/>
  54.     <Item50 ID="OnlinePackageManager 1.0.1.2"/>
  55.     <Item51 ID="TurboPowerIProDsgn 0.0"/>
  56.   </Packages>
  57. </CONFIG>
  58.  
P.s CEF4Delphi package doesn't change anything about that

valdir.marcos

  • Hero Member
  • *****
  • Posts: 650
Re: Cannot Create Package [Windows 64, Lazarus 2.0-RC3]
« Reply #5 on: March 14, 2019, 03:18:14 pm »
In case of application conflicts, i have listed all of the installed tools bellow

Adobe Flash Player 32 {NPAPI, PPAPI}
Bitnami WAMP Stack
Boost Libraries for Embarcadero Developer Tools
Embarcadero Interbase XE7
Embarcadero RAD Studio 10.1 Berlin
FastReport5 Embarcadero Edition
Microsoft VisualStudio Express 2012 for Windows Desktop - RUS
Git v2.17.1.2
Entity Framework Designer for VS2012
FileZilla FTP Client 3.41.1
HashTab 6.0.0.34
HHPMod
HTML Help Workshop
HxD Hex Editor 2.2.1
Java SE Development Kit 8 Update 181 {32, 64}-bit
JPEXS Free Flash Decompiler
Microsoft .NET Compact Framework 3.5
Microsoft .NET Core SDK - 2.1.202(x64)
Microsoft .NET Core SDK 2.1.402(x64)
Microsoft .NET Framework 4.5 Multi-Targeting Pack
Microsoft .NET Framework 4.5 SDK
Microsoft .NET Framework 4.5 russian localization
Microsoft DirectX SDK (March 2008)
Microsoft Games for Windows - LIVE Redistributable
Microsoft Help Viewer 2.0
Microsoft Identity Extensions (<== i don't know where it come from)
Microsoft {Office, Project, Visio} 2016
Microsoft SQL Server 2012 Data-Tier App Framework
Microsoft SQL Server 2012 Data-Tier App Framework (x64)
Microsoft SQL Server 2012 Express LocalDB
Microsoft SQL Server 2012 Management Objects
Microsoft SQL Server 2012 Management Objects (x64)
Microsoft SQL Server 2012 Native Client
Microsoft SQL Server 2012 Transact-SQL Compiler Service
Microsoft SQL Server 2012 Transact-SQL ScriptDom
Microsoft SQL Server Compact 4.0 SP1 x64 RUS
Microsoft SQL Server Data Tools - RUS(11.1.20828.01)
Microsoft SQL Server Data Tools Build Utilities - RUS(11.1.20828.01)
Microsoft System CLR Types for SQL Server 2012
Microsoft System CLR Types for SQL Server 2012 (x64)
Microsoft Visual C++ 2005 Redistributable - x64 8.0.61000
Microsoft Visual C++ 2005 Redistributable - x86 8.0.61001
Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.6161
Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.6161
Microsoft Visual C++ 2010 Redistributable - x64 10.0.40219
Microsoft Visual C++ 2010 Redistributable - x86 10.0.40219
Microsoft Visual C++ 2012 Redistributable (x64) - 11.0.61030
Microsoft Visual C++ 2012 Redistributable (x86) - 11.0.61030
Microsoft Visual C++ 2013 Redistributable (x64) - 12.0.40664
Microsoft Visual C++ 2013 Redistributable (x86) - 12.0.40664
Microsoft Visual C++ 2017 Redistributable (x64) - 14.15.26706
Microsoft Visual C++ 2017 Redistributable (x86) - 14.15.26706
Microsoft Visual Studio 2010 Tools for Office Runtime (x64)
[(i'm not sure which program installed 2010 tools, but i haven't installed MSVS2010)]
Notepad++ (32-bit x86)
Nvidia PhysX
OpenAL
OpenIV (GTA 3, 4, 5 and EFLC mods creation panel)
Orca
qBittorent [(it depends on qt framework)]
Resource Hacker Version 5.1.6
Sothink SWF Editor [(i don't need this anymore)]
SQL Server System CLR Types
Steam
TortoiseSVN 1.11.1.28492 (64 bit)
Visual Studio Extensions for Windows Library for JavaScript 2.1.30324.52 [php won't compile without it]
WinRAR 5.60 (64-bit)
Необходимые компоненты для SSDT (Required Component Package for SSDT)
Служба языка T-SQL Microsoft SQL Server 2012 (T-SQL language service for Microsoft SQL Server 2012)
Commandpromt/Commandline utilities for Microsoft SQL Server 2012
Языковой пакет для средства просмотра справки (Language package for help viewing service (Microsoft) 2.0 - RUS)

When trying to create a package (doesn't matter from which place), i see 'Division by zero' error
Lazarus IDE:
IDE is displaying in docked mode (sparta_DockedFormEditor and AnchorDockingDsgn installed)
Win32 extension is installed
P.s CEF4Delphi package doesn't change anything about that
If you can, uninstall all your programming tools, and use some tool to clean and optimize Windows Registry. For example:
https://www.ccleaner.com/ccleaner/registry-cleaner

After that, install a virtualization solution to separate your programming tools. For example:
https://www.virtualbox.org/

So, you could have C++, Delphi, Lazarus etc on different virtual machines.

Try to use last Lazarus stable version (now is 2.0.0) instead of its previous RC3.

Your can even try newer options with fpcupdeluxe:

fpcupdeluxe - Lazarus wiki
http://wiki.lazarus.freepascal.org/fpcupdeluxe

wp

  • Hero Member
  • *****
  • Posts: 5454
Re: [SOLVED] Cannot Create Package [Windows 64, Lazarus 2.0-RC3]
« Reply #6 on: March 14, 2019, 03:34:51 pm »
I agree that you should take this opportunity to switch to the stable Laz v2.0. But I disagree with the usage of "optimization" tools such as CCleaner - these tools cause more damage than optimization if not applied carefully.

The new original Laz version should run correctly. It does here, so it should for you, too.

Begin adding your packages, one by one. After each step test whether your error has already re-appeared. If it did you know which package is the faulty one.

Lazarus trunk / fpc 3.0.4 / all 32-bit on Win-10

HuntingKashket

  • New member
  • *
  • Posts: 16
  • I'm not a quitely obsessed
Re: Cannot Create Package [Windows 64, Lazarus 2.0-RC3]
« Reply #7 on: March 14, 2019, 03:39:22 pm »
When trying to create a package (doesn't matter from which place), i see 'Division by zero' error
Lazarus IDE:
IDE is displaying in docked mode (sparta_DockedFormEditor and AnchorDockingDsgn installed)
Win32 extension is installed

Screenshot and package list is attached

Configuration:
Intel Celeron n3060 (@1.6Ghz)
RAM 4Gb (1777Mhz, working in 800mhz mode)
If possible, increase your RAM to 8gb or 16gb.

Quote
Windows 8.1 Pro [x64] with latest updates
If possible, format your notebook and install Windows 7 (lighter and faster) or Windows 10 (better option than 8.1 if you have 8gb or more of RAM).

Quote
Package list
Code: XML  [Select]
  1. <?xml version="1.0" encoding="UTF-8"?>
  2. <CONFIG>
  3.   <Packages Count="52">
  4.     <Item0 ID="FCL 1.0.1"/>
  5.     <Item1 ID="LazUtils 1.0"/>
  6.     <Item2 ID="CodeTools 1.0.1"/>
  7.     <Item3 ID="LCLBase 2.0.0.3"/>
  8.     <Item4 ID="DateTimeCtrls 1.5.1"/>
  9.     <Item5 ID="CmdLineDebuggerBase 0.0"/>
  10.     <Item6 ID="DebuggerIntf 0.1"/>
  11.     <Item7 ID="LCL 2.0.0.3"/>
  12.     <Item8 ID="ImagesForLazarus 1.0.1"/>
  13.     <Item9 ID="pascalscript 0.0.0.1"/>
  14.     <Item10 ID="SDFLaz 0.1.1"/>
  15.     <Item11 ID="lazmrumenu 1.0"/>
  16.     <Item12 ID="LazOpenGLContext 0.0.1"/>
  17.     <Item13 ID="CEF4Delphi_Lazarus 1.0"/>
  18.     <Item14 ID="LazControls 1.0.1"/>
  19.     <Item15 ID="SynEdit 1.0"/>
  20.     <Item16 ID="fpvectorial2aggpaspkg 0.0"/>
  21.     <Item17 ID="LazDebuggerFpLldb 0.0"/>
  22.     <Item18 ID="Printer4Lazarus 0.5"/>
  23.     <Item19 ID="IDEIntf 1.0"/>
  24.     <Item20 ID="SynUni 1.0"/>
  25.     <Item21 ID="LazC 0.1"/>
  26.     <Item22 ID="LazActiveX 0.1"/>
  27.     <Item23 ID="customdrawn 0.0"/>
  28.     <Item24 ID="AnchorDockingDsgn 1.0"/>
  29.     <Item25 ID="EditorMacroScript 0.0"/>
  30.     <Item26 ID="DBFLaz 0.1.1"/>
  31.     <Item27 ID="SQLDBLaz 1.0.2"/>
  32.     <Item28 ID="ToDoListLaz 1.0.2"/>
  33.     <Item29 ID="TAChartLazarusPkg 1.0"/>
  34.     <Item30 ID="ProjTemplates 1.0"/>
  35.     <Item31 ID="fpcunitide 0.1"/>
  36.     <Item32 ID="ChmHelpPkg 0.2"/>
  37.     <Item33 ID="jcfidelazarus 2.0"/>
  38.     <Item34 ID="TurboPowerIPro 1.0"/>
  39.     <Item35 ID="ExternHelp 1.3"/>
  40.     <Item36 ID="InstantFPCLaz 1.0"/>
  41.     <Item37 ID="MemDSLaz 1.2.1"/>
  42.     <Item38 ID="leakview 1.0"/>
  43.     <Item39 ID="printers4lazide 0.0"/>
  44.     <Item40 ID="RunTimeTypeInfoControls 0.1"/>
  45.     <Item41 ID="DateTimeCtrlsDsgn 1.5.1"/>
  46.     <Item42 ID="LazControlDsgn 0.0"/>
  47.     <Item43 ID="SynEditDsgn 1.0"/>
  48.     <Item44 ID="idefilebrowser 0.2"/>
  49.     <Item45 ID="lazdaemon 0.9.9"/>
  50.     <Item46 ID="QuickFixExample 0.0"/>
  51.     <Item47 ID="sparta_DockedFormEditor 0.0"/>
  52.     <Item48 ID="LazDebuggerGdbmi 0.1"/>
  53.     <Item49 ID="TAChartAggPas 1.0"/>
  54.     <Item50 ID="OnlinePackageManager 1.0.1.2"/>
  55.     <Item51 ID="TurboPowerIProDsgn 0.0"/>
  56.   </Packages>
  57. </CONFIG>
  58.  
P.s CEF4Delphi package doesn't change anything about that
Thanks, but it doesn't supports windows <= 8, and windows 10 to be honest (screen, keyboard drivers is incompatible)
« Last Edit: March 14, 2019, 09:14:49 pm by HuntingKashket »
Andew Zenin

HuntingKashket

  • New member
  • *
  • Posts: 16
  • I'm not a quitely obsessed
Re: Cannot Create Package [Windows 64, Lazarus 2.0-RC3]
« Reply #8 on: March 14, 2019, 03:41:41 pm »
Please test the release version (Lazarus 2.0.0), not the release candidate (RC). Also try the fixes branch (2.0.x). You can get it by using fpcupdeluxe : https://forum.lazarus.freepascal.org/index.php/topic,34645.0.html

I figure out where it comes from, i tried to convert delphi package ( https://github.com/kashaketcompany/php4delphi ), and then it fails with unknown error, after that studio crashes and cannot create packages until you delete last projects info.
This is a bug   %)
Andew Zenin

valdir.marcos

  • Hero Member
  • *****
  • Posts: 650
Re: Cannot Create Package [Windows 64, Lazarus 2.0-RC3]
« Reply #9 on: March 14, 2019, 03:42:56 pm »
Please test the release version (Lazarus 2.0.0), not the release candidate (RC). Also try the fixes branch (2.0.x). You can get it by using fpcupdeluxe : https://forum.lazarus.freepascal.org/index.php/topic,34645.0.html
How bad! making him read a 80-page thread... :)

fpcupdeluxe - Lazarus wiki
http://wiki.lazarus.freepascal.org/fpcupdeluxe

HuntingKashket

  • New member
  • *
  • Posts: 16
  • I'm not a quitely obsessed
Re: Cannot Create Package [Windows 64, Lazarus 2.0]
« Reply #10 on: March 14, 2019, 03:50:26 pm »
I agree that you should take this opportunity to switch to the stable Laz v2.0. But I disagree with the usage of "optimization" tools such as CCleaner - these tools cause more damage than optimization if not applied carefully.

The new original Laz version should run correctly. It does here, so it should for you, too.

Begin adding your packages, one by one. After each step test whether your error has already re-appeared. If it did you know which package is the faulty one.
Delphi pas/dpr file conversion after docked design installing (sparta_DockedFormEditor + AnchorDockedDsgn )caused this problem, - if the conversion fails then studio will crash, and after that it will be trying to open unsuccessfully converted project at start, which makes difficult to create project of failed type (Desktop Application, Module, Package, etc.)
« Last Edit: March 14, 2019, 04:13:49 pm by HuntingKashket »
Andew Zenin

HuntingKashket

  • New member
  • *
  • Posts: 16
  • I'm not a quitely obsessed
Re: Cannot Create Package [Windows 64, Lazarus 2.0]
« Reply #11 on: March 14, 2019, 06:21:27 pm »
To fix that, tried to remove links to the broken package [this error could happen even if you just removed project files, while IDE is closing], but it doesn't change anything(
If it help, there's a dump file https://mega.nz/#!PU5GGQQL!fo_ApE8LcfKwP8I7G3FkO0nAMctH6Ri90fv9X6b0kCU
I have collected IDE errors: https://mega.nz/#F!qJRzUIwL!2Vp0IrL3bauKFBnRkdpplg
Also, this bug has broken my compiler links [includelinks.xml] (renamed synedit to ynedit)

Editing info:
includelinks.xml [rem php4delphi, ynedit=>synedit]
environmentoptions.xml:
"packageEditor_PHP4Delphi", "PackageEditor_SVGPackage",
"PackageEditor_CEF4Delphi_Lazarus" a42="PackageEditor_NewPackage"
<== Look at this, the IDE firstly loads opened packages master, and the new package master is opened after all of it

<PackageEditor_php4DelphiR2010>
        <Caption Value="PackageEditor_php4DelphiR2010"/>
      </PackageEditor_php4DelphiR2010>

InputHistory.xml:
<FileDialog InitialDir="C:\Users\Andrew\Documents\GitHub\php4delphi – копія\Source\">
=> C:\dev\sefrolov\CEF4Delphi-master\demos\SimpleLazarusBrowser\

<Conversion>
      <Delphi Package="C:\Users\Andrew\Documents\GitHub\php4delphi – копія\Source\php4DelphiD2010.dpk"/>
    </Conversion>
=>
<Conversion>
</Conversion>

packagefiles.xml:
    <Item4>
      <Name Value="php4DelphiD2010"/>
      <Filename Value="C:\Users\Andrew\Documents\GitHub\php4delphi – копія\Source\php4DelphiD2010.lpk"/>
      <LastUsed Value="2019/03/14 16:33:46"/>
    </Item4>
=> [none, and changed item count]
« Last Edit: March 14, 2019, 09:14:01 pm by HuntingKashket »
Andew Zenin

JuhaManninen

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3583
  • I like bugs.
Re: Cannot Create Package [Windows 64, Lazarus 2.0-RC3]
« Reply #12 on: March 15, 2019, 12:36:21 pm »
I figure out where it comes from, i tried to convert delphi package ( https://github.com/kashaketcompany/php4delphi ), and then it fails with unknown error, after that studio crashes and cannot create packages until you delete last projects info.
This is a bug   %)
Indeed!
One unit in the project, namely ZENDTypes, has an include file name in quotes. Like this:
Code: Pascal  [Select]
  1. {$I 'PHP.INC'}
It is a valid syntax but so rare that it was maybe not tested. The bug was in Codetools function FindNextIncludeDirective. I fixed it in r60675. It will be merged to fixes_2_0 branch later.
Please test with Lazarus trunk or with the fixes branch after it is merged.

For me the IDE did not crash but the conversion terminated with an exception. That is expected when something unusual happens.

HuntingKashket

  • New member
  • *
  • Posts: 16
  • I'm not a quitely obsessed
Re: Cannot Create Package [Windows 64, Lazarus 2.0-RC3]
« Reply #13 on: March 15, 2019, 10:03:08 pm »
I figure out where it comes from, i tried to convert delphi package ( https://github.com/kashaketcompany/php4delphi ), and then it fails with unknown error, after that studio crashes and cannot create packages until you delete last projects info.
This is a bug   %)
Indeed!
One unit in the project, namely ZENDTypes, has an include file name in quotes. Like this:
Code: Pascal  [Select]
  1. {$I 'PHP.INC'}
It is a valid syntax but so rare that it was maybe not tested. The bug was in Codetools function FindNextIncludeDirective. I fixed it in r60675. It will be merged to fixes_2_0 branch later.
Please test with Lazarus trunk or with the fixes branch after it is merged.

For me the IDE did not crash but the conversion terminated with an exception. That is expected when something unusual happens.

Thanks  :D
fantasies about going multi-platform is closer to the reality as never before
Lazarus is awesome
Andew Zenin

HuntingKashket

  • New member
  • *
  • Posts: 16
  • I'm not a quitely obsessed
Re: Cannot Create Package [Windows 64, Lazarus 2.0-RC3]
« Reply #14 on: March 17, 2019, 04:05:59 pm »
I figure out where it comes from, i tried to convert delphi package ( https://github.com/kashaketcompany/php4delphi ), and then it fails with unknown error, after that studio crashes and cannot create packages until you delete last projects info.
This is a bug   %)
Indeed!
One unit in the project, namely ZENDTypes, has an include file name in quotes. Like this:
Code: Pascal  [Select]
  1. {$I 'PHP.INC'}
It is a valid syntax but so rare that it was maybe not tested. The bug was in Codetools function FindNextIncludeDirective. I fixed it in r60675. It will be merged to fixes_2_0 branch later.
Please test with Lazarus trunk or with the fixes branch after it is merged.

For me the IDE did not crash but the conversion terminated with an exception. That is expected when something unusual happens.
Still getting this error on the trunk version of Lazarus and FPC, i've removed all {$I 'filename.inc'} declarations includes, maybe it fails because of phpExtensionBuilder.pas (170,3)
Code: Pascal  [Select]
  1.  S :=  'library ' + FProjectName + ';' + CRLF +
  2.   '{$I PHP.INC}' + CRLF +
  3.  
or
Code: Pascal  [Select]
  1. //{$IFDEF PHP530}
  2.  
also, it's already have defines for the FPC, but doesn't have an lpk-file and some of the used functions is now deprecated, so i can't just use it 'as is'
« Last Edit: March 17, 2019, 04:07:51 pm by HuntingKashket »
Andew Zenin